Trying to work this out...

Need some help

So I've managed to 'tweak' an existing outfit, just to tell myself I can do this. I got the outfit to show up in the outfitters purchase area, but it shows a picture of the light blaster, and uses the description of the same. How do I create a description that will attach itself to my new outfit?

Upon further examination, it's not working right.

What I did was copy the Pirate Viper Bay, and made a few changes. I changed the allowed nuber of ships from 4 to 8, I upped the weight (tonnage) and cost of the outfit, and I skipped the scan thingy so that it doesn't show up as illegal. However, I can still only buy 4 Pirate Vipers, per bay.

Any ideas?

Firstly: there should be a field in the outf resource to change description and picture. Remember, each weap resource is linked to an outf resource, which controls its appearance in the outfitters. It sounds like you duplicated the bay to weap 128, and now you are actually overwriting the light blaster's weapon, but not it's outfit description. If you don't want to overwrite stock outfits, make sure you are using an ID number that isn't used it the data files.

I don't have the files open to look, so I'm just guessing, but outfit ammo can be a bit confusing, because there are multiple max ammo numbers (one on the weap, one on the ammo, I believe). Make sure they are all set to what you want.

Hope that helps!

@jalisurr, on 08 August 2011 - 06:20 AM, said in Trying to work this out...:

I don't have the files open to look, so I'm just guessing, but outfit ammo can be a bit confusing, because there are multiple max ammo numbers (one on the weap, one on the ammo, I believe). Make sure they are all set to what you want.

Easy fix: set the ammo OUTF's maximum to something ridiculously huge, like 32,767 (the highest number you can fit in Nova's 16-bit numeric fields). Then use the WEAP's MaxAmmo field to constrain how much ammo a weapon can have.

This means that if MaxAmmo is 50, and you have 5 of the WEAP, your total ammo is 5 x 50 = 250.

I've looked it through several times, and I still can't get the bay to hold more than 4 vipers, and now I can buy the vipers without owning a bay! If I ask really nicely (Please?) would one of you lovely folks volunteer to let me email it to you, and you can have a look at it and tell me what I'm doing wrong?

And possibly even fix it and tell me how you did it?

I use EVNEW for Windows.

Or you could just post a link to it here so we can download it. You can use a service such as Dropbox to accomplish that easily.

@darthkev, on 09 August 2011 - 01:32 AM, said in Trying to work this out...:

Or you could just post a link to it here so we can download it. You can use a service such as Dropbox to accomplish that easily.

I joined DB, but I the way I see it, I can only 'share a folder.' I'm fairly certain that if I just look at the file, and C&P the web address, it'll send you to your own homepage, as I don't see a unique ID in the web bar. What am I missing?

Well, I'm DLing the program. That's probably it. Standby.

In your Dropbox folder you should have two folders; a Public folder and a Photos folder. Put the plug-in (zipped up, of course, in a .zip format or something similar) in the Public folder. Then right click on the plug-in and go down to Dropbox in the pop-up menu. Then click on 'Copy Public URL'. Post that link here and we'll be able to download it.

http://dl.dropbox.co...20%28Qty%29.rez

There. It's not zipped, but it's only about 143kb.

I found your problem. You have the modified bay pointing to the original bay in the Nova Files. This is why the changes you are making with the new weapon are not showing up in-game. You also have the fighters, essentially the ammo for the new bay, acting as the weapon itself, not as ammunition.

Here, I've fixed it for you. Pirate Viper Bay (Qty)

@darthkev, on 09 August 2011 - 03:37 PM, said in Trying to work this out...:

I found your problem. You have the modified bay pointing to the original bay in the Nova Files. This is why the changes you are making with the new weapon are not showing up in-game. You also have the fighters, essentially the ammo for the new bay, acting as the weapon itself, not as ammunition.

Here, I've fixed it for you. Pirate Viper Bay (Qty)

Now I KNOW I'm doing something wrong. I DLed the file from the link you provided, and it's still screwy. Exactly the same as it was before I gave it up for you folks to DL. Buying the vipers without the bay. The only difference is that now the bay won't even show up in my secondary selection screen. ::Facepalm::

Would it be possible that in my attempt to copy the original Pir Vip bay specs I corrupted the original file? Would that explain my problems?

God I wish I could have someone stand behind me to point this stuff out. It'd be a hell of a lot easier that way.

This post has been edited by Avi Kerensky : 09 August 2011 - 06:39 PM

See what I mean when I said I was having a hard time. lol

I'll be back to my development computer this weekend. I'll take a look for you then. Right now I'm stuck with my netbook with nothing installed on it.

Fair Enough. Thanks.

Darthkev's version didn't work because the maximum valid ID for a weapon is 383. He had it as 444, which is why it caused weird behavior. Try this:

Attached File Pirate Viper Bay (Qty).rez.zip (60.14K)
Number of downloads: 1

@jalisurr, on 14 August 2011 - 05:35 PM, said in Trying to work this out...:

Darthkev's version didn't work because the maximum valid ID for a weapon is 383. He had it as 444, which is why it caused weird behavior. Try this:

Attachment Pirate Viper Bay (Qty).rez.zip

First things first, I set the number to 444. So that was my fault. Thanks for the correction, and the new file. Secondly, Everything hooks up like it should.

Thanks for the fixed file. Maybe now I can look it over and figure things out for good.

I have to look it over again, and make a Desc for the Viper itself, and I want to modify the Desc for the bay. Thanks again 🙂

Edit: Once I have the descriptions worked out and stuff, I'm going to post this on the AmbrosiaSW add-on area. I'll be sure to cite Jalisurr and Darthkev for their help.

Thanks again, guys.

This post has been edited by Avi Kerensky : 14 August 2011 - 09:02 PM

For those interested, I have redone the plug, given it a new name, and submitted it for Ambrosia to post. Should be available for DL on Tuesday or so, provided they approve it.

You can find it by name: CamSti Enterprises Viper Bay and Fighter

Any questions/comments/concerns, email me: Sailorkerensky@yahoo.com

Now I'm trying to create a ship (Modelled after the IDA Frigate), but again, even though I change all the numbers, it's still super-imposing my specs onto the damn shuttle (as opposed to the L Blaster, as last time). I've changed the numbers, I've created desc's and pict's (Corresponding with the (I thought) correct ID numbers) and it's not working right. I've also put in several weapons (Railguns, missile jammers, hellhound launchers, etc) but only the railguns are showing up.

Would I be out of line asking if there's a video out there somewhere that can show me what I'm doing wrong?

This post has been edited by Avi Kerensky : 15 August 2011 - 03:34 AM

Log in to reply