Fighters not Appearing

TC help

Well I've started yet another TC, this one basically makes the player start in a mother of all scout ships that has fifty fighters. However the fighters aren't actually showing up. When I start the game and I scroll over to the weapon it says that it has no ammo. The ammo and the fighters do work if you buy the fighters. But this is impossible to do early in the game as you don't get to an outfitter for a long while. I have tried everything I could think of. I redid them, I deleted them and created them in a new file, I double and triple checked, everything says, the ship should have the fifty fighters. Yet they still don't work. How can I correct this?

Fighter bays are a little wonky with chär resources. You can start the player in a ship that has a fighter bay, but the fighters won't be given to the player. You could try having the chär resource grant fighters to the player fighters upon starting, or use a crön to give the player fighters on the first day.

The above are theories, I haven't tried them at all.

I had this problem with the flares I tried to make, it used launched "fighters" to create the flare effect, but even though I assigned ammunition to the weapon when I got it in game there was no ammo. Also, like you say, it worked if I bought it separately. I wish I could say I found a solution, but unfortunately I was stumped as well.

The tricky part seemed to be, even though it told me it didn't have ammunition, I couldn't buy any more ammunition. This suggests to me that the ammo was just not appearing for some reason. Are you seeing that behavior also?

QUOTE

The tricky part seemed to be, even though it told me it didn't have ammunition, I couldn't buy any more ammunition. This suggests to me that the ammo was just not appearing for some reason. Are you seeing that behavior also?

No this is not the case, it's almost like the player isn't starting with the ammo. I can buy more I can sell them I can launch them and watch them be blown to bits. They just aren't there when I start.

QUOTE

Fighter bays are a little wonky with chär resources. You can start the player in a ship that has a fighter bay, but the fighters won't be given to the player. You could try having the chär resource grant fighters to the player fighters upon starting, or use a crön to give the player fighters on the first day.

This may be my best option, I'll have to test it out sometime, I hope it does work and I'll get back to you if it does or doesn't.

I suppose a mission would work too, but the plug starts you in the storyline from day one, and implementing it in the story will be a problem. After all finding a convenient gun on Stratus 8 is different then finding 50 fully functioning fighters in a weapons cache.

You can have the mission grant the player fighters and explain it as needing to take up orbit or land in order to finish preparation of the launch bays. It can't be done in open space or you would be vulnerable to possible attack.

I'm seeing this bug still, as well. If I find a way to fix it, I will post it in this post.

So, my findings;

I am not able to start with ships in a ship bay.
I am not able to eject using that carried ship under any circumstances.
Occasionally, ordering the carried ship to attack will apparently cause it to either disappear or stop being your escort.
Using a cron to give you ammunition for the ship weap only works if you dock with a planet first.
Ammunition can be bought normally.

You were right, IT 000, this bug is extremely annoying.

This post has been edited by Shlimazel : 28 May 2010 - 05:21 PM

So fix that along with the graphics glitches, and call it EV Nova 1.1.1

Fix it? I wish. I can't figure out what is going on, even after consulting every piece of documentation and reference material I can get my hands on. Searching for information yields no answers. I'm thinking about making a plug for stock nova to have you start in a carrier and see if that flubs too. If it doesn't, I may have something to look into, but if it does then I'm lost.

(edit)

It does flub. If you start in a carrier in stock nova, you don't have any fighters. Aaaggh.

This post has been edited by Shlimazel : 29 May 2010 - 10:47 AM

So why not set it that an invisible auto-aborting mission starts in the char resource that grants the player the fighters? Simple.

Yes, I know, but that's not going to fix the problems though, because even if I do that it won't fix my inability to eject using my carried ship. That's what I'm trying to do, and I think that the Eject not working is somehow a consequence of the problem of the fighters not appearing. Otherwise, I can't account for these strange mixups I'm encountering.

Did you make sure the fighters are set as escape ships? I've experimented with this a bit and I have had none of the problems you've described in giving the player the fighters at the start.

This post has been edited by DarthKev : 29 May 2010 - 05:28 PM

Log in to reply