SOS

Hey guys (anyone that's still around that is). I picked up an old powerbook g4 with MacOS 10.4 and Classic, for s###s and giggles, and have a hankering to play all the Empire plugs and especially Pale! damn that one is good. Anyway, I've installed EV, retrieved my activation codes and thought I should be good to go, however when I start the game is is super stuttery. I can't do much of anything. I've tried to increase the memory, add a plug in, shut down other apps in the back round. Nothing. Its so stuttery, and commands don't register, like I have to hit esc multiple times before it the computer executes. I've tried to email Ambrosia, but never heard anything back, I think they don't really care about a game so old. So any help would be greatly appreciated.

Thanks,
Pundit

What's the game's speed set to? Also, I'm assuming this powerbook is used. Is it possible its own hardware isn't quite 100% operational?

Are you trying to play the original EV? That is, not EV Nova with the Classic plugin?

If that's the case, you're sadly out of luck. The original EV will not run properly on OS 10.4 or later. 😞

You can play EV in the SheepShaver PPC emulator easily enough. I've been doing that to pilot the B&B's text-based game.

I'd forgotten about SheepShaver. I should try it again.

Log in to reply