Water current

Hello, I am a newbie and love this game. Got stuck several time and manage to pass through. But what i cannot do, still, is beat the strong water current in the opposite side. Can anyone help me with that? Thanks

This post has been edited by cyl82 : 21 February 2009 - 10:52 AM

Welcome to the boards, cyl82. Enjoy your stay!

I don't know where you're referring to, but

Spoiler

there's a form that you will get that allows you to get past strong currents

. In the meanwhile, keep searching for other places to go.

Thanks a lot. I was able to get to it after a few play

I did it!!!! I finally finished the game. The best game ever. But now i am bored and wondering if anyone know another game like this one to play on Macintosh. Good luck to everyone else; this forum helped me a lot.

Download all the Ambrosia games and play ’em all…that is, if you don’t have a Classic computer, skip the older ones, but…:)

Particularly I’d recommend EV Nova and Cythera, although the latter is a Classic game…still, they are two of the best Ambrosia games of all imo.

Outside of Ambrosia, my scope isn’t that vast, but I’d reccomend Cave Story/Doukutsu Monogatari, another 2D side-scrolling RPG, if you haven’t already played it.

Doukutsu rocks. Unfortunately it doesn't work under Leopard on my MacBook Pro :(. I should really install it again on bootcamped Vista.

At all? Or just a bug with the item screen?—if it’s the latter, then upgrade Leopard and it should work fine.

At all, on any version of Leopard thus far. Window appears for a few seconds then exit unexpectedly.

Console calls it Exception Type: EXC_BAD_ACCESS (SIGBUS); Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000, and the usual masses of code that goes along with such things.

It works happily on Leopard on my Mac mini.

This post has been edited by MartiNZ : 27 April 2009 - 04:02 PM

Strange…works fine on my MacBook Pro, which is using the newest version of Leopard. I assume you’ve tried all the usuals (deleting preferences, reinstalling program, etc.), right?

Yeah I have, although I made sure to keep a copy of the prefs with <5 min hell achievement set :). I've tried downloading it from a couple of different places also, just in case. A mystery, and it really does seem to be just my machine sigh.

That's amazingly creepy.

iReport.

Log in to reply