Listing all current Coldstone issues

What are they?

Hi all,

Would it be possible to get a current list of all known issues with Coldstone? A list of all (currently) supported platforms would be great as well.

I'm working up some documents here, and I need the data for my research.

Best wishes,

Dave Williams
Project Lead @ ATMOS for Escape Velocity NOVA

Known Issues:
- Games created have no functionality in OS 10.3 and greater.
- Music does not work in Windows XP(haven't tested it in any other version) for Coldstone games.
- you are unable create new save files in compiled games in OS 10.2.
- the preferences for Coldstone get corrupted easily; for no apparent reason, thus causing crashes.

Platforms supported for Coldstone built games:
- Mac OS 8.1 or higher (PPC)
- Mac OS 10.0.4 - 10.2.8 (PPC)
-Windows 95, 98, ME, 200, XP

Platforms that support Coldstone the application itself:
- Mac OS 8.1 and higher (PPC)
- Mac OS 10.0.4 and higher (Will run under Rosetta)
- Note: Windows Compatibility may be implementable because Coldstone was created in Realbasic.

That's all I can think of right now.

This post has been edited by GrahamVH : 30 October 2006 - 08:22 PM

Thanks, GrahamVH. I'll add those to the list.

Poor PNG support?

In what way is PNG support broken? Examples with screenshots would be great.

The actual editor behaves unstably in OSX. Stamp outlines don't appear in the OSX binary (only in the Classic binary). The 'Run/Launch' button is supposed to create a 'quickie' binary for testing in OSX without having to build a proper binary - it was disabled in CS 1.0.1 because it worked inconsistently, and often created unstable binaries.

There should be a long and detailed list of issues around somewhere, pipe. I'll see if I can still dig it up.

Found it: here. A bit old perhaps, but still outstanding issues.


Excellent. That, too, assists.

  1. If you place a healing potion in the inventory of an NPC, he will use it indefinitely without it ever running out making the NPC virtually impossible to defeat unless one can do so in one or two blows.

  2. An NPC with zero movement will, on occasion, chase after the player or retreat. This is really strange if the NPC is a tree which the player is supposed to chop down. At some point the tree might run away or follow the player.

  3. In doing plugins for PoG, if one removes the plugin from the p. folder after playing it through, and then re-installs the plugin to play it through again with the same character, the player will "remember" the maps which were unique to that plugin. Items which were found in that map originally will not be there for the second play through.

Not quite sure what you mean by the last point, RD. Assume I don't know how the Coldstone plug-in system works.

Okay, -- a short explanation: There are essentially just two types of plugins for a role-playing game (RPG) such as Pillars of Garendall , the "cheat" plugin and the "storyline" plugin.

The cheat frequently allows the player to acquire more money or more health or stronger weapons to make the game easier but does not change the basic game in any way. This is sometimes done by adding a key-stroke event which, for example, just puts 1000 gold pieces into the player's inventory. Since gold is an item which is found in the game itself, removing the plugin from the folder does not remove gold from the player's inventory. If a unique weapon is given to the player, however, the weapon will no longer be there when the plugin is de-activated.

The storyline plugin is closer to a total conversion (TC) for EV Nova. It adds new territories, new characters, new quests, and frequently, new items to the existing story without altering the main story itself. Most often there are rewards for playing through the plugin. Those rewards will still be with the player when the plugin is de-activated unless they are unique creations of the plugin. In other words, the experience gained, the added wealth, etc. are still there as the player continues through the game. The super sword he got will be gone.

I'm sure you probably knew all of that. Now here is where PoG differs from EV Nova. In PoG there is a definite exit point at which time the game is over and the player has done the final quest and cannot return to fight any more battles. Having done that once, most players start a new character and play through again resolving not to go through the final gate, but instead continue to roam the Kingdom of Garendall increasing their experience level, strength, wealth, etc. Storyline plugins add diversions and fun to the whole experience. But questions arise. "Did I find all that the author put there?" "Did I make the best choises?" "Can I beat that beast I ran away from if I am stronger?" So the player may want to play the plugin through several times. In the main game, the "fog of war" prevents the player from seeing areas of the map he has yet to explore. This is true for the first time experience of a plugin as well. However, when the plugin is removed from the folder, the access to new areas is closed but not the "memory" of those areas.

Let me give you a hypothetical example. The player drops a new plugin, Voyage to Valhalla , into his folder. Now when he goes to the Bleeding Forest, he finds a new cave there. This cave transports him to new maps he has never seen before. While exploring this new territory, he finds three "magic apples" which can be used to bribe a witch to let him pass into Valhalla. And so on. "Boy, that was fun. I want to try that again." Remove the plugin from the folder. The cave no longer exists in the Bleeding Forest. Now put the plugin back in the folder. "Ah, there's the cave." Go to what should be unexplored land and find out "We've been here before. Somebody stole the "magic apples" I'm supposed to give to the witch."

There are work-arounds for the plugin developer in Coldstone, but if would be much better if Coldstone allowed the elements of the plugin to completely erase when the plugin was not activated.

I have been verbose. I hope some clarification of my point was evident.

Aha, I think I've got it.

Depending on how the mechanism works internally (and I have no idea), fixing this may be tricky. If they've done it this way for the reasons I think they have, it probably reflects a fairly significant underlying weakness in the plug-in architecture.


One of the original beta testers, Glenn (Mathews), had a site listing many of the still-existing bugs, but the links to that site return an error message now. By typing "bugs" in the search feature for this forum I came up with 8 pages of posts. I've just spent most of today going through the first five pages and sorting out what I believe were true bugs and discarding those I deemed most likely "user errors." Perhaps Glenn still has his list available somewhere. The list I've come up with is not long, but it covers essentially what's surfaced in the past four years.

In OS 9, memory is not always released after being used (i.e. you place an item (using memory). Then you place another one, using the same amount of memory again. And then again, and probably, ColdStone has crashed from lack of memory at this point).

The "undo" function does not work in the map editor.

Placing stamps in the endgame event crashes the game.

Stark Bledfast lists a number of bugs/wishes in

Ellrx in

In fact, the whole thread has much information if one is willing to plow through the frustrations and off topic digressions of some.

I got caught out a few weeks ago where some bad code I wrote earlier this year came back to bite my project team. I hadn't been properly alocating or clearing some memory I was using.

It caused all manner of instability. Given that Coldstone appears to be leaking, so to speak, I wonder if that might be part of it.


Andiyar has been more thorough in his research than I. I see now that he provided a working link to Glenn's bug list and I must have glossed over it on first reading. My apologies. 🙂

More on the memory issue: I found, when working in 9.2.2, that I had to increase the memory allotted to CS to a very large chunk or the application would freeze, quit, or crash my machine in the middle of drawing a map or constructing an animation. Hitting "save" periodically during these operations did not correct the problem. I would have to save, quit CS, and re-open on a regular basis to avoid loosing all the work I had done. If I added more than about a dozen frames to an animation in one session I was courting a crash.

I don't know if this has been addressed but the Run button in the editor is very unstable. It does not work often - even when running the Classic version of Coldstone.

Also, I just would like it if the race editor could do a little more. You cannot set restraints on characters based on their race, just class. (for example I can't say in the elf editor: Only Heavy Weapons, or say that they can only be certain classes).

Edit: Yeah I figured features weren't what you wanted but figured what the heck. ;-D

This post has been edited by Pixor : 08 November 2006 - 03:37 PM

Assuming this goes ahead, features will be very very low on the priority list. We'd simply be trying to get Coldstone working as advertised.

I also noticed that if you give a potion to a NPC not only will he/she use it over and over again, but the potion will also heal you as well as the NPC... I think that the hero should rely on his/her own potions... Thanks! 🙂

Log in to reply