Game Bug

All my other games work fine except Emerald Fire, the game I am working on for the time being. Whenever I start it up it automatically quits. I don't see anything including just the screen going dark getting ready to go to the loading screen, it just starts for a millisecond, then stops... Should I just make a new game and transfer everything or am I doing something wrong, though all the events and locations are correct.

I suggest you try increasing the memory, or make sure other applications are not running at the time.

it's currently at 6000, what do you suggest.

Don't know. 16000. Or increase it until it works. Hope it works for you.

Thanks, i REALLY hope it works =P, but if it doesn't, what would you suggest?


Dangit! I increased it ONCE and it worked, but then I made a quick change and it didn't work again, even when I increased it to 130000....

This post has been edited by gamingstaff : 29 April 2005 - 07:14 AM

It will quit like that when you have a stamp, NPC, item, etc. that you placed in the map and then removed or renamed it from the folder. I'd open every map and see if that's the case. It will ask you for an alternate.

It will quit like that also if you made a global and then used it in an event and then deleted the global from the options menu. No easy way to fix that though. You'll have to go through your events, knowing what globals are still there.

Neither are true, no globals yet still even in the graphics stage and no map items missing or renamed sigh at times like these I long for the update if it's a bug :p.

Where does it teleport you? If it tries to teleport you to a location you deleted it will crash.

gamingstaff, this doesn't sound like a bug in the software to me. You say that all of your other games work, just this one doesn't. The bug is in the game. If a thorough search of all you have done won't show you what is wrong, the next step is to rebuild the game from the start, examining each componant as you go. I know that is a lot of work, but I think all of us have "been there, done that." So you have my sympathy.

Crashes usually happen when the game engine get a directive it cannot process. It could be a call for an item (stamp, NPC, location, etc.) which does not exist, or as simple as a typo in some instruction. Example: You want to go to location "Woods_1" but typed "Woods-1" instead.

I wish you good luck with the detective work.

Now this really is screwed 😛 . I can play the game perfectly when I build a release, just not when I run it....... and that derned You have made this game with an unregistered- blablablablabla gets annoying, but whats going on???