custom level colors are screwd up

I'm working on a custom level, I have a bunch of things including a large background of graph paper, but when i start the level, all of the colors are messed up. Everything is black and when i move or fire the images dont get cleared. what can i do to fix this?

Could you please make a screenshot of this? I think I saw that before, too, but I was never able to reprocude it. Try saving and reopening the file, this action made the bug disappear when I saw it the last time.

screenshot:

Attached File(s)

This post has been edited by red3x : 10 December 2006 - 04:39 PM

Hmm, I was thinking of a bug in the editor, but not in the game itself.

Did you only use one big sprite for the background? I mean, did you resize 1 background sprite to cover your entire level? I think if a sprite isn't displayed entirely on your screen (so if it is really big) SketchFighter will have problems with showing only parts of it.

@freq245, on Dec 10 2006, 04:48 PM, said in custom level colors are screwd up:

Hmm, I was thinking of a bug in the editor, but not in the game itself.

Did you only use one big sprite for the background? I mean, did you resize 1 background sprite to cover your entire level? I think if a sprite isn't displayed entirely on your screen (so if it is really big) SketchFighter will have problems with showing only parts of it.

ah thats probably it. I had one large tiled image for the entire map. ill break it up thanks.

EDIT: this works, but it takes forever. is there a better way?

This post has been edited by red3x : 10 December 2006 - 05:01 PM

The issue is explained in the editor manual. Basically sprites whose center are too farr of the player are culled out and no longer drawn.

For instance you could start from Picquilarius' template; anyway it's indeed a bit long, but it's something you only have to do once.

The problem is that Ive already started making my map. Is there anyway to copy all my objects into the graph paper template?

None that I know of, unfortunately. 😞

to put down the graph paper quicker, use the snapping settings in the bottom left corner of the editor. (just lay a bunch down, then use edit mode to move around with snapping)

Log in to reply