Corrupted Pilots?

A good way through my last Anathema test-run, Nova started glitching out a little. This has happened before, where dialog boxes will get displayed in the upper-left corner of the screen while the mask stays in the middle (so, say, you'll have a mission briefing, outfitter screen, or galaxy map displaying in the corner and a big white box where whichever interface should be).

This has always been solved by rebooting Nova. And that fixed it just fine this time, too. Except apparently my pilot got corrupted along the way, too. It won't open, unless you have Nova load another pilot and then load the pilot in question, in which case it starts the corrupted pilot out with a blank slate (Shuttle, 10,000 credits, etc.) I've been keeping (infrequent) backups, and I can always just set the bits to get me back where I started, but is this behavior normal? Well, not normal, but has anyone else seen it? I haven't really played any 1.1 without Anathema installed, so I don't know if it's my plug that's causing it (I have no idea how that would happen), if it's a known issue, or if there's just something corrupted in my flies, perhaps. Anyone lend a confused modder a hand?

This post has been edited by Archon : 05 November 2011 - 10:29 AM

Well, it's only a very small help to know this, but I've never experienced the problem you're speaking of through many hours of playing through evn 1.1. I haven't really played evn 1.1 (or any of them since 1.08 for that matter) without the plug "satori" either. It modifies/tweaks most/all the ships, outfits, various missions and other things.

mooo

While I personally have yet to experience a corrupted pilot period (knock on wood) I have heard of similar issues involving v1.1.0 in where the graphic for interface windows will be drawn in the wrong place while the mask is in the right place. The result of a corrupted pilot has also been reported along with that glitch many times in the past. As far as I know, the only possible solution would be to switch of of EVN (do NOT quit it) and immediately make a backup of the pilot in use. Then restart EVN to fix the glitch and, if the pilot has been corrupted as should be expected in such an instance, toss the bad one and put in the copy you just made.

NOTE: I say 'possible solution' because I have yet to hear of someone trying this at all, let alone if it worked or not. As I myself have not been able to test it either, it's based almost entirely in theory at this point.

Thanks for the info. Lets me narrow down my troubleshooting a bit, and hopefully the precaution will work out.

The copy of EVN I'm running was transferred from my old iMac (the one that died) over to the new one. In the 3 years of running the old iMac, I never had this problem. It makes me wonder if 1) there's a problem operating on this machine or 2) there was a problem with the transfer. I didn't transfer over the registration info or preferences, though, so that likely rules them out as likely culprits.

This post has been edited by Archon : 06 November 2011 - 02:13 AM

Log in to reply