Government fleet always attacking player

Even at start, with positive legal record

I'm having an other weird problem... My second government's (ID=129, if there's anything hard-coded for it) warships are always shown as hostile, though they don't ever seem to attack the player - they generally jump out as fast as they can, even if he is in a shuttle. This is even at the start of the game, when the player has a positive legal record with them (citizen, and the planets/systems are friendly and will let him land).

I checked everything I could think off - the gov is not xenophobic, the player has no positive record with any enemy government, he has no outfit/ship with any scanning bits set and anyway the gov has no illegal bits set either, the military düde has nothing weird going on (IA is set to interceptor)... it's getting annoying. Could it be anything hard-coded since IIRC gov 129 has always been the "main ennemie" in the EV serie?

What is the inherent government of your ship?

Is the government flagged to "Alway Attack Player"?
Is the düde flagged as wimpy traders?
Does the government have obscenely low MaxOdds, or do its shďps have zero strength?
What is the government's CrimeTol?

@zacha-pedro, on Oct 13 2006, 06:46 PM, said in Government fleet always attacking player:

What is the inherent government of your ship?

-1.

@qaanol, on Oct 13 2006, 07:45 PM, said in Government fleet always attacking player:

Is the government flagged to "Alway Attack Player"?

No.

@qaanol, on Oct 13 2006, 07:45 PM, said in Government fleet always attacking player:

Is the düde flagged as wimpy traders?

No, interceptors (the other düde from that gov I have are brave traders and they behave as expected - friendly normally, fight back when attacked).

@qaanol, on Oct 13 2006, 07:45 PM, said in Government fleet always attacking player:

Does the government have obscenely low MaxOdds, or do its shďps have zero strength?

No (300) and no (15, 200 and 600 vs 2 for my shuttle).

@qaanol, on Oct 13 2006, 07:45 PM, said in Government fleet always attacking player:

What is the government's CrimeTol?

I really, really don't get it. Must be a stupid mistake but really can't see where.

This post has been edited by Kinniken : 13 October 2006 - 02:44 PM

They appear on radar as red dots, and if you target one it has red brackets around it? But they run away? That's how I understand what you're saying.

Are the ships flagged to run away if out of ammo-using weapons, and not have any ammo or ammo-using weapons?

Is the government "Nosy"?

What government owns the systems and the stellars within the systems where you see these ships?

@qaanol, on Oct 13 2006, 09:56 PM, said in Government fleet always attacking player:

They appear on radar as red dots, and if you target one it has red brackets around it? But they run away? That's how I understand what you're saying.

Are the ships flagged to run away if out of ammo-using weapons, and not have any ammo or ammo-using weapons?

YES! Thanks! Well done, you solved half of it! (well, haven't tested it yet but the ships indeed had that flag set and had guns without shells).

@qaanol, on Oct 13 2006, 09:56 PM, said in Government fleet always attacking player:

Is the government "Nosy"?

What government owns the systems and the stellars within the systems where you see these ships?

It's not nosy, and the s˙sts are its own. However the spöbs in them mostly belong to sub-governments of the main one for mission addressing reasons (same class, allied, same values for everything). Gov 128 has the same system which doesn't cause any problems as far as I can see.

Just tried it with the ammo problem fixed and... it fixes the whole problem. I'm not getting attacked anymore. Hmm, would that flag be unused in EVN by any chance? 😉

That's good. I was just going to comment that they always attack me and run away.

Log in to reply