How do I make this work?

Can't buy things on my planets

I'm working on a plugin with new planets and I want to be able to buy things (auto recharger, gravimetric sensors, etc). My problem is I can't buy anything I want. I don't own any of the items and the outfitter won't let me buy them. I need to fix this problem since I want to release this plugin at some point (it will be release #2). I have tried playing around with things in EVNEW but it still won't work. Anyone have any ideas?

EDIT: I think I solved the problem. I needed to set the contribute bit field on my ship to match the require bits for the outfit I wanted. Any thoughts are still welcome.

This post has been edited by Ant'Iglias II : 31 July 2006 - 08:34 PM

Hmm, So you already own a ship and you built a ne spob, right? If the outfits arent showing up, then its the tech level. You just need to put a numer like 7 in the tech level to get what you want. But if they are showing up, then it may be the require bits.
Why dont you create debuglog.txt and put it in your nova folder. Run nova and then open up the text file. Post whats in there on the board. And also, see if you can take a screenie of your spob, i want to compare it to mine, cuase mine work perfect.

(EDIT) NVM the above, the require bits of your ship is the problem. I had the similar problem also, hers the post Cant buy outfits for my ship, the ship i designed Try that, and also, you forgot to mention that you made a ship. 😄

This post has been edited by chronodrago : 31 July 2006 - 08:41 PM

Log in to reply