Message Buoy Strings and System Changes

Annoying problem

I'm working on a plugin where I have several systems with message buoy strings (the ones that appear at the bottom of the screen when you first jump into the system). Anyway, when a certain mission bit is set, the system changes governments. This is done by having the first version of the system appear when the mission bit is not set and the other version of the system visible when it is set. The second system does not have a message string (the message buoy field is set to -1). The system change occurs as planned, but the new system still displays the old message string when I jump in. I can't make it go away. I even tried having a message string with nothing in it or a space in it and the old one still appeared. Is this a bug in the engine or does someone know of a way to fix this?

It's a bug in the engine. You could work around it by placing the versions of the systems one pixel apart, but that would mess up automatic links and exploration (exploration can be solved by the Xxxx NCB operator, though, and links can be done explicitly). Doing this would avoid issues with not getting random missions to spobs in the system that change.


Or you could put a blank STR resource and get the second one to call that.

The Cheat, on Jul 18 2005, 06:20 AM, said:

Or you could put a blank STR resource and get the second one to call that.
View Post

Tried that, it doesn't work. 😞

So there's no chance of getting the engine bug fixed I take it?