Obron Strike Mission Bugged

Friendlies think I'm enemy

Don't know precisely whats happening but essentially when I enter the Obron system with the mission to kick Voinian arse and take names my own allies in the Earth Force fleet throw every missile they got right at me killing me instantly, for some reason thats friend or foe is finnicky in first minute or so where I am seen by the AI as Voinian.

How can I fix?

Yeah I am definately being flagged as hostile to both sides for no reason.

This post has been edited by Chromium Lord : 12 June 2010 - 11:50 PM

Before we can fix this we need to find the cause. What ship are you flying? If you're flying a Voinian ship, UE ships will attack you on sight. Additionally, if you are seen as hostile in the Obron system, that would also cause the UE to attack you.

Which mission are you trying to do? A defense mission from Outpost Sigma, or the taking of Gualon Station?

QUOTE (DarthKev @ Jun 13 2010, 05:04 AM) <{POST_SNAPBACK}>

Before we can fix this we need to find the cause. What ship are you flying? If you're flying a Voinian ship, UE ships will attack you on sight. Additionally, if you are seen as hostile in the Obron system, that would also cause the UE to attack you.

Which mission are you trying to do? A defense mission from Outpost Sigma, or the taking of Gualon Station?

I was flying the Helian, "Destroy the Voinian Task Force" destination Obron system in Voinia space, return to Outpost Gamma when complete.

I am doing an Earthforce mission, the system is owned by Voinia, I think the problem is that the UE ships are being spawned at the same time as the Voinians and thus are considered on the same side.

**edit yup, what happens is when I hyperspace into the system instead of there being a Earthforce fleet behind me a Voinian one warps in instead so I get confused as being voinian and get attacked by everyone, all missions regarding Obron do this to me as I canceled it and eventually got a new one though different, same thing I end up squashed like a bug.

This post has been edited by Chromium Lord : 13 June 2010 - 01:21 AM

Pretty much every mission where I get a mission to "Destroy Voinian taskforce" or "Destroy Voinian Munitions Convoy" leads to me being squashed by both the UE and Voinian fleets, what I see is that a voinian and UE fleet both warp in next to me and after a few seconds the UE fleet starts firing at me and then the Voinian fleet, according to my friend whose parsing through the mission code he can't figure out what could possibly be wrong with the mission, they shouldn't be shooting me.

Even from what little you've told me (trust me, there's much more to know about this if you knew how to code plug-ins) I see no reason the UE should be attacking you, though there is one possibility: you keep saying 'Earth Force' instead of 'United Earth' or 'UE'. Are you using a plug-in that changes the government or are you just saying the wrong word? If you are using plug-ins, those could be the cause if something was done wrong in the plug-in.

Could you also post a pilotlog? This will give me some more information that might help.

I am just using the wrong word (force of habit) we both are heavy duty Babylon 5 fans so we tend to call em that tongue in cheekly.

To be specific I am playing the total conversion of EV Nova to EV Override on the PC.

I think we had gotten them to not attack me one by my friend editing it so the UE had a higher tolerance for criminal activity (though I don't recall ever shooting any friendlies) though when we tried I think the same mission again later they still attacked me after working fine once.

Its happening in the dreadnaught mission now as well, I warp in and suddenly a whole swarm of missiles swarm at me from UE ships.

A higher tolerance for crime fixed it? Strange...

Which port of EVO to EVN are you using? The 'official' port is buggy in some areas, this one possibly being one of the errors in it. If you are using the official port, I suggest using Guy's Port. It's very reliable and has few (if any) bugs.

I'd also like to see that pilotlog and know if you are using any other plug-ins.

Here it is if it helps.

edit: Apparantly according to my friend somehow the UE fleets that spawn in missions appear to be flagged to fight me and thus the fix hes doing will be to switch government 140 with 128, 140 insists on killing me.

Attached File(s)

This post has been edited by Chromium Lord : 13 June 2010 - 04:16 PM

QUOTE (DarthKev @ Jun 13 2010, 08:41 PM) <{POST_SNAPBACK}>

A higher tolerance for crime fixed it? Strange...

Which port of EVO to EVN are you using? The 'official' port is buggy in some areas, this one possibly being one of the errors in it. If you are using the official port, I suggest using Guy's Port. It's very reliable and has few (if any) bugs.

I'd also like to see that pilotlog and know if you are using any other plug-ins.

QUOTE

EV Override for Nova 1.1.1 (8.2 MB)
27 February 2009: 1.1.1 released with improved thumbnail quality on Windows.
Port of the original EV Override to the Nova engine.

Do you mean this? I think we are already using this.

Don't switch the governments, I doubt that will work. gövt 128 and 140 are exactly the same with the exception 140 is immune to the player's weapons. Switching them will probably only allow you to kill the UE ships instead of being defensive.

No, I think the cause is something else. I can't be sure if you are using Guy's Port, the information you gave gives very little information as to who made it. When you start it up, does it say 'Port Authority' in flashing letters covering the EVO logo in the main menu? If so, that's the 'official' port, not Guy's Port.

k, currently acquiring the new port now but I tested the changes my friend made and it worked, the UE ships stopped attacking me and I was able to complete the missions normally.

Although when my friend used my save while they the UE ships turned red/hostile he couldn't target them and I presume they couldn't target him.

But yeah, we're gonna try Guy's update and see if it works.

This post has been edited by Chromium Lord : 13 June 2010 - 05:51 PM

Actually, the AI breaks rules regarding targeting. Just because you can't target them, doesn't mean they can't target you. In fact, if you were to make a ship with a plug-in that couldn't be targeted, and then pit it against another AI ship, that AI ship would still be able to target it and fire turrets on it. I know, it sucks, but there's nothing we can do.

Did your friend make any changes other than switching the gövts, or was that it? I'm truly surprised it worked. Even when considering the fact that particular flag (the one making certain ships immune to player weapons) is kinda buggy when it comes to missions sending ships in with that flag, those kinds of bugs don't involve making the immune ships hostile to the player when they shouldn't and only occur when they are meant to escort the player (meaning they show up as escorts you can command, not normal ships).

This is all very intriguing, I've never heard of a problem like this before. Also, you said your friend couldn't target the UE ships. This shouldn't be unless they were special versions of UE ships set to not be targetable. I suppose it's possible WinNova's Engine works differently, but I doubt it very much.

Bottom line, this doesn't sound like a bug so much as sabotage. Well, not sabotage, but something more complex than a simple error in programming.

One last note: Guy's Port is NOT and update, it is a separate version of the EVO TC for Nova. Don't use it with any other port, that would probably cause problems.

This post has been edited by DarthKev : 13 June 2010 - 11:14 PM

Log in to reply