Azdgari Missions

Please help. I completed the Azdgari recruitment mission, and went to the Azdgari training planet. I tried to get the small fleet of newbie pilots to the designated planet (or station?) but one was destroyed. The computer said that I had failed the mission, so I landed to see if I could do it again, but nothing came up. I went to all of the other Azdgari planets, but still nothing. I have tried several times to join the Azdgari, but something like this keeps getting in my way. I want to get through this problem, so someone please help.


Where is Gamit?

--The Eye is Upon you--
If you look long enough the Sun isn't that bright.

I think you can get the mission again at Muit, but i´m not sure

Wise words are not the same as a wise mind, cause maybe they have the text from somwhere else...

Go to Muid (not Muit) and there you'll get a mission to fly a group of trainees to Garit (not Gamit). Hope that helps.

To Escape Velocity: Nova and Beyond!
Millennium. Its coming, prepare for it.
Coming to the (url="http://"")EV Chronicles(/url).

I generally just reload the pilot if one gets lost on the way, but you should be able to get it again from Muid - it would be awfully mean if you couldn't, as then you'd be strandless forever :frown:!