What went wrong?!?

Ben, I have had Ferazel's wand installed on my computer since the week it came out. Just this past week I mentioned the gray armadillopines in the Labyrinth. But now, for some bizarre reason, my computer is telling me that I need to put the CD in before I can open it again. That's not terrible, but here is the worst part: I CAN'T FIND THE CD ANYWHERE!!!!! Therefore, I can't play Ferazel's Wand until either 1)I can get the program fixed, or 2)I can find the CD. Seeing as I have looked everywhere in my house several times for the CD, I don't think option 2 will work out very well. Here's my main question: Why would my computer (an iBook) insist on having the CD in before I can play again? 😕

I hope it's alright for me to post an answer to your questions, and I'm assuming the question isn't a sarcastic one but a genuine one, but the reason for the CD needed is for Ambrosia to avoid the always present Piracy problem that occurs with mac games. Needing the CD is one way (though not always effective) of solving the problem of piracy.

I would assume Ambrosia would send you another CD for the price of shipping..

Hope that helps.

I had the same problem. Rebuilding the desktop may fix it in your case. If not a permanent fix after that, you may have to re-install Ferazel, make sure the CD is not in the drive, then rebuild the desktop. That fixed all of my alias icon problems and the goofy requests for the CD. (But that means you will have to find the CD.)Good Luck!


I had that happen, too. Turns out I just need to reset the memory and close some other applications. I had turned-off virtual memory earlier that day and forgot. When I tried to play, the program noticed the change and asked for the CD. I'm not sure if the game went back to normal because I had inserted the CD or what. But the next time I played, I closed all applications except the ones I needed --leaving plenty of memory for the game.

Maybe that will help?


I've always been putting in the CD. Thought you always had to! I have plenty of other games that you DO have to--no question.

If doing the suggestions above doesn't work, I would imagine you could always ask Ambrosia for a new CD, as long as you're registered. They might charge you something for the duplicate, but then again...



(This message has been edited by lindawing (edited 02-19-2000).)

I seem to recall the game asking me to put the CD in the first time I played the game, but only the first time. Everytime since then that I've played I have played without the CD. The only thing I can think of is that somehow the file that told the game that you've played before has gotten corrupted or deleted. If you really can't find the CD anywhere (where was the last place you had it?) I would suggest you contact Ambrosia (help@ambrosiasw.com), explain the problem, and see if they can help you figure out a reasonable solution.


Check out my Ferazel's Wand Player's Guide at (url="http://"http://employees.3gi.com/~ereid/ferazel")http://employees.3gi.../~ereid/ferazel(/url)

I jusy remembered that I had recently turned virtual memory off for another program. I just turned it back on. Hopefully that will help. Thanks for the suggestion, Amorisse! 🙂


WOOOOOOHOOOOOO!!!!!!! It worked!!!!! Thank you SO MUCH for the suggestion, Amorisse. You're a life saver (What flavor are you? Cherry? Lemon?)!!!! I'll stop rambling now. Here's just a suggestion to anybody whose computer wants the CD after the 1st time: Turn virtual memory on. If that doesn't work, ask Ben. 😄 😄 😄 😄 😄 😄 😄 😄 😄