Uplink 1.3.4 won't remember my registration code

Major Problem

I recently upgraded from 1.3.3 to 1.3.4. I hadn't played in a long while (because of the still ongoing problem regarding third-party programmable mice), so my license code had expired. Fine, I know the drill - I sent for a new code. Problem solved, right? Wrong!

I duly entered my new code in the registration application; it was accepted (success message). When I ran Uplink 1.3.4 however, it overwrote the licence file (in preferences) and all the game options which are only available to registered players are not available.

Quit Uplink, run the registration application again - guess what? It wants the code again. Repeat ad nauseam; same thing. As soon as Uplink is run, the code is erased. Throw away the license file; it might be corrupted - that happens sometimes - no change.

Anyone else experiencing this?

On a side note (hinted at above): anyone else ever tried using their Logitec or Kensington mouse/trackball to play Uplink on OS 9.x? Doesn't work, does it? Annoying huh? Especially that this has been reported again and again since the dawn of Uplink for Mac. How many updates have not addressed this now? I lost count. I'm losing patience.

I'd suggest that you download and re-install Uplink.

What about your standard Apple mouse?

nfreader, on May 9 2005, 01:11 PM, said:

I'd suggest that you download and re-install Uplink.

What about your standard Apple mouse?
View Post

I downloaded the full installation of 1.3.4, importing no user or theme files from the previous version. The problem persists, as described previously.

  1. Enter regristration code - the registration application signifies this is successful. Relaunch of this application and click of "enter key" confirms "you've already registered"...
  2. Launch Uplink - watch the modification date of the Licence file change in the background - the Uplink application itself is overwriting the file (shouldn't it only read the file to confirm that it is a valid licence?).

Although I knew it would be yet another waste of my time, I did download a fresh copy Uplink, not twenty minutes before posting this. Before trying anything, I did the following:

  1. I deleted the previous licence file.
  2. I disabled all extensions not essential to running Uplink.
  3. I restarted my Macintosh - a 9600 with a G3 upgrade card (Newer Technologies), zapping PRAM (held down through at least three "zaps" because the first one sometimes doesn't take) and rebuilding the desktop. Both of these actions were probably unnecessary, but eliminate any shifting of "blame" to those issues.
  4. I ran a thorough systems diagnostic, virus check, modification dates check - in short, the works. Result: clean system.
  5. Ran the registration application; successful acceptance of my licence code (acquired yesterday).
  6. Finally ran Uplink. Same result as before, licence file overwritten - A relaunch of the registration application, shows it wanting the code again. Repeat ad nauseam - no change.

Final verdict: whatever the problem is, it is neither in my system nor in my understanding of Macintosh systems in general. With the exception of the ongoing mouse problem, none of the previous Uplink versions ever behaved in this manner in conjunction with the system as it is currently configured. That the problem persists, even when a minimum necessary configuration is used, clearly indicates that any "fault" lay with Uplink 1.3.4 itself.

The mouse problem is only solved by disabling Kensington drivers, regardless of which mouse is used. This necessitates a restart (with a different extensions set) solely in order to play Uplink. This problem is separate from that described above, and has existed (and remained unaddressed) since the advent of Uplink on the Mac. This naturally leads one to wonder how long it will be before the licence code problem I am experiencing is resolved?

For the record, I have always dutifully registered any and all Ambrosia softwares which I have found useful or fun (i.e, have wanted to keep). In recent years, however, I've noticed a decline in Ambrosia's QA, typically with regard to out-of-house developments which are marketed through Ambrosia, the exception (so far) being the EV-series, which has been very well supported. The long-running debacle surrounding the disappearance of the developer of "Slithereens," leaving that application long unable to function under OS 9.1 is a good case in point.

Yes, I know this was finally resolved, long after OS 9 was declared "dead" by the great "saviour" of Apple, Steve Jobs, so Ambrosia is to be thanked for seeing this one through, but, my gosh, did it take a long time! I can remember my daughter crying because she couldn't play Slithereens anymore. By the time the issue was resolved she had long since lost interest. Perhaps a small thing in the grand schemes of the software industry, but a little too close to home for the customer. Anyone who would even consider disagreeing obviously lacks a heart and probably a soul as well.

I know, I've gone off on a tangent somewhat, but I feel these things need to be said. Companies are comprised of people, after all. Forming a company does not render its constituent members (individual people) immune from social responsibility and accountability, any more than forming a national government does. To believe otherwise is a recipe for corporate failure.

Of course, if I was an angsty teenager, I could simply replace all of the foregoing with "Ambrosia sucks!" But, my intention is not to flame, but to correct. Being somewhat older (an understatement) and a computer professional with three decades in systems analysis, gives me, I feel, the right. I'm expressing a considered opinion, not merely venting frustration (though there is that, too, to be sure).

In light of my long experience, therefore, and to get back to the original topic of this post: there's nothing that you can think of to try on my end, that I haven't already thought of, tried, or dismissed as absolutely not the problem.

Thank you for trying, though.