Trouble hosting games [demo]

The "New Game" button doesn't work.

I'm running Mac OSX 10.3.9 on an iMac 700mhz and 256mb RAM.

When i try to click on the New Game button, the main menu disappears and all i can see is a chat window:

Posted Image

Is it just my Mac or it's a problem of the application?

It's just your Mac. That's rather odd thinks

Ye, that's strange...i can join and play other games no problem, but still i can't host...
Is there any file or extention needed by Defcon that i might not have?

Make a report in the bug reports topic.

Check ~/Library/Logs/Defcon/ for a file called "debug.txt". This file is recreated every time you start up Defcon. So, attempt to start a new game, and post the debug log either here, or in the bug reporting topic.

xander

I'll report the Defcon log shortly, btw u should know that many windows users have the same problem in the introversion software support forums, some say the new game button doesn't work, others can host but can't join, or the tutorial button only shows the loading window and doesn't start (i have this problem as well).

SDL Version: Compiled against 1.2.11, running with 1.2.11
Defcon 1.4 mac built Apr 18 2007
Parsing archive main.dat...DONE
Client listening on port 49457
Parsing Coastline data (1864 islands) : 61ms
Parsing International data (2753 islands) : 57ms
Parsing City data (2745 cities) : 151ms
Parsing archive sounds.dat...DONE
Initialising SDL Audio
Frequency: 22050
Format: 36880
Channels: 2
Samples: 512
Size of Stereo Sample: 4
Authentication key set : ''
Connection established to MetaServer, listening on Port 49458
Received Authentication : : (keyID -1) : Accepted
Auth Key accepted as DEMOKEY :
Requesting data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Requesting data from MetaServer : DemoLimits
Received data from MetaServer : DemoLimits
Received data from MetaServer : LatestVersion
Requesting data from MetaServer : MOTD
Received data from MetaServer : MOTD
Requesting data from MetaServer : UpdateURL
Received data from MetaServer : UpdateURL
CLIENT : Disconnected
EclRemoveWindow failed on window LOBBY
Server started on port 49461
CLIENT : Attempting connection to Server at 151.70.106.192:49461...
Started requesting public IP:port for socket 8
MetaServer : WAN registration enabled
MetaServer enabling UDP broadcast for LAN discovery...SUCCESS
MetaServer : LAN registration enabled
MetaServer encountered error sending data
MetaServer : LAN registration disabled
Socket 8 identified as public IP 151.70.106.192:49461
CLIENT : Disconnected
SERVER : Shutting down...
SERVER : Shut down complete
Disconnected from MetaServer
MetaServer : WAN registration disabled
MatchMaker encountered error sending data

This post has been edited by Dalek7 : 22 April 2007 - 12:50 PM

You might want to remove your authentication key from your post.

Quote

CLIENT : Disconnected
EclRemoveWindow failed on window LOBBY

Does that mean the client application isn't connected and then i can't host games but i can join them cause the port is different?! I'm not an expert of logs and debugs...

Quote

You might want to remove your authentication key from your post.

It's the demo version auth-key...

Exact same thing is happening to me. Deleting all preferences and library entrances and reinstalling from scratch achieves nothing. I got three good games in before it hit me.

Defcon 1.4.2
iBook G4 1.33
768mb RAM
Tiger 10.4.9

Log in to reply