Over sensitive trackpad

While running DEFCON in a window (haven't check in full screen), scrolling from the track-pad on a 2.16 GHz Intel Core 2 Duo MacBook Pro seems to be oversensitive.

For example, when going to right click on a unit (two fingers on track-pad + click) it occasionally zooms in just enough so that the cursor is no longer on the unit. Other times when trying to zoom in a little, after I take my fingers off the track-pad, it zooms back out. This doesn't happen if I zoom in using more than a slight nudge.

This post has been edited by kickme : 19 April 2007 - 10:10 PM

Try adjusting your speed in System Prefs.

For some reason it seems to be hard to get scrolling on a trackpad to work properly in games. I have seen this happeen time and time again in just about any game I've tried playing with my trackpad. It's certainly not specific to Defcon, but it might help to try as Mackilroy suggests. Other then that, I'm not sure there's much else you can do except try and find a mouse somewhere or minimize your scrolling.

I'm not quite sure what you mean by having two fingers on the trackpad and clicking to act as a right-click. The standard modifier as far as I know is to hold down command or control while clicking to trigger a secondary click.

I tried that, to no avail and it made reading websites slow. And all the mice I've got are one button

In System Prefs, there's an option to turn it on.

Trackpad scrolling is not over-sensitive so much as it is inaccurate. Basically, if you scroll anything but up really quickly (such as up slowly, or down at any speed) the game zooms out. This means that you can only zoom in really quickly, because the only time the game interprets your scrolling as being up is when you scroll up quickly.

I'm sure this has something to do with the different behaviours of mouse and trackpad scrolling, because I've noticed it in some other games too.

You might to try changing Options -> Other -> Zoom Speed. It's intended to help with this situation. Or just scroll using the Q and E keys. Finally, as Andcarne mentions, you can control-click rather than right-clicking.

I too am having the trackpad scrolling issue. It's odd, because it worked just fine with the Steam version in Crossover.

Log in to reply