Laggy error fighting a boss

I got Sketchfighter with the Christmas sale pack, and tried it out a few days ago.

I was expecting it to be slow, given how old my computer is, but to my surprise, everything worked great, without the slightest hint of lag.

Right up until the third boss I encountered, I believe it's in the factory. It's a square surrounded by 4 platforms firing red beams.

Pretty much as soon as I enter the room my CPU usage shoots to maximum and the game freezes up. Screen'll change every 5-30 seconds with an update.

Is this a known bug, is there a memory leak, is this simply a more resource-intensive section of the game that my older computer can't handle?

I've got a 733 G4, 640 MB of RAM, running 10.3.9.

Are there cheat codes, can I instakill the boss and then go about the rest of the (non-lagged) game?

Can I hack my file to give it whatever weapon/bonus the boss is hiding?

Or am I screwed?

Z

@zair, on Jan 7 2009, 08:46 PM, said in Laggy error fighting a boss:

Is this...simply a more resource-intensive section of the game that my older computer can't handle?

I believe that's the reason. 😞

I have a 700 MHz G4 (sunflower) iMac with the same amount of RAM...I had bought SketchFighter when it was version 1.0.2 and I'd never experienced any really significant lags during any part of the entire game. However, after upgrading to version 1.1, I was unable—due to lag—to play past that exact boss you'd mentioned. I can't remember what changes were made in that area, but I can assure you that they weren't anything extremely significant.
In short, I'm fairly sure Ambrosia would be willing to send you the earlier version if you were to e-mail support and ask them. 😉

By the by, version 1.1 has three new fantastic levels designed by the creator of the game, so be sure to hang on to those. (There was a topic which detailed exactly where those levels were kept, but I can no longer find it.)
Also, any other add-on levels you may download will be compatible with version 1.0.2.

This post has been edited by Lamkin : 08 January 2009 - 10:00 PM

I also had that problem, and I got around it by staying near the entrance, shooting only when I needed to, and a bit of luck. It takes a little longer, because sometimes the boss will stick to the bottom of the arena, but it worked for me. if you asked Edwards, he might be able to help with the technical details, or maybe hacking the save file.
I hope that the strategy I described above will help. Also, if you set it to run in fullscreen with the resolution as low as possible (something like 800x600 at millions of colors) the game will run a little bit better.

-K

This post has been edited by Kasofa1 : 08 January 2009 - 08:59 PM

@kasofa1, on Jan 8 2009, 06:58 PM, said in Laggy error fighting a boss:

(I)f you set it to run in fullscreen with the resolution as low as possible (something like 800x600 at millions of colors) the game will run a little bit better.

Er...or...you could just do that. 😊
Using a resolution of 800 x 600 shouldn't give you any lag whatsoever. (I tested it out on my machine.) Then you could switch back after defeating that particular boss. (Just make sure you save before you switch.) Hopefully that problem won't happen again during the rest of the game. :unsure:
Meh. I still prefer using version 1.0.2 with a constant resolution of 1024 x 768, but it sounds like your best (and easiest) bet might simply be to go with option two.

This post has been edited by Lamkin : 08 January 2009 - 10:12 PM

Thanks for the help, both of you.

I ended up switching to 640 by 480, fullscreen, and turned the sound off, and used all my missiles and beam weapons to kill it as quickly as possible. For some reason, lag was less bad if I kept it on the screen with me. Also, if I took too long to kill it it quickly became unplayably slow.

But I beat it, got the reward, saved, and have moved on a decent bit. Yay!

Z

That's great! I hope you like the rest of the game!

-K

Yeah, that part taxes older computers. Good to see it's been worked out, though. 🙂

Log in to reply