[help] can't set keys (not even back to normal)

Hello,

I've really enjoyed sketchfighter. I've found the difficulty just right and it's fun.

I tried to change the keys on my macbook and it just doesn't work at all. If I click a key, it always sets the key to F2. So know, quite a few of my first player controls are F2 and I can't figure out how to change them back.

I've tried to set keys from the main menu and from within a game. Both aren't working for me.

Is there a manual way to set keys? or to reset them back to normal?

Any recommended key settings for 2 player on a laptop?

Thanks,

felix

ok... so I fixed it. I pressed "caps lock" and it started working properly. But...

I've remapped the "caps lock" to a "ctrl" key in system preferences... personally, this is seems like a little UI type bug.

felix

Recommended key settings? I'd recommend getting another keyboard. 😉

And that's rather odd – no one ever reported this bug during beta testing – hmm.

It sounds like something that unfortunately isn't all that uncommon in games, where the game is interpreting keyboard presses without the benefit of system-wide keyboard remappings. I run into this from time to time; I use the Dvorak keyboard layout instead of Qwerty, and every once in a while I'll hit a game that reads my keypresses as Qwerty even then. I suspect that swapping control and and capslock managed to confuse whatever Sketchfighter is using to read the keyboard. Or something like that, anyway.

Log in to reply