Resetting Darwinia?

I've just tried installing some of the mods from; they worked fine.

However, I've just gone and messed up Darwinia by trying to overwrite one of my existing profiles that I'd created for one of the other mods.

I'd followed the instructions and restarted with the mod selected, then I created a new profile. It worked perfectly. Then I deleted that mod, and found that I couldn't restart without it. I reinstalled it, restarted, then unloaded the mod and then restarted, and Darwinia was back to normal.

Then I installed another mod, restarted with it running, but I decided I didn't want to created another profile (as I can't seem to delete any old ones) so I tried to overwrite the profile I created for the previous mod then it quit (and now won't start up) with a "Fatal error" (Invalid map file specified). And I can't get rid of the first mod or the second mod, or either mod, and make it work again. :wacko:

Here's the text of the report it created: :blink:


VERSION : macosx-full-1.2.2
ERROR : 'Invalid map file specified'

====== STACKTRACE =======

retAddress = 0x5fbf8
retAddress = 0x5f9b4
retAddress = 0x56acc
retAddress = 0x58db4
retAddress = 0x42228
retAddress = 0x2cfd8
retAddress = 0x863f4
retAddress = 0x86550
retAddress = 0x7873c
retAddress = 0x5dc4
retAddress = 0x92882878
retAddress = 0x907726a0
retAddress = 0x9076a7c4
retAddress = 0x9286cc80
retAddress = 0x936062c0
retAddress = 0x936061ac
retAddress = 0x93605cf4
retAddress = 0x9360589c
retAddress = 0x92883884
retAddress = 0x928836e4
retAddress = 0x91451a40
retAddress = 0x914518dc
retAddress = 0x91451734
retAddress = 0x9312c204
retAddress = 0x93603fe4
retAddress = 0x93603b08
retAddress = 0x9360006c
retAddress = 0x936f08bc
retAddress = 0x60a0
retAddress = 0x2f60
retAddress = 0x2dd4
retAddress = 0xbffffdbc

Any ideas as to how I can reset it without (if possible) losing my previous profiles etc ? :unsure:

<span style='color:gray'>EDIT:
The first mod loaded was ArcadeRemix 1.01, and the second was EnemyWithin 1.3.1, both by trickfred.

**Please note: by giving the names of the mods means that I hold no-one (other than myself) liable. There's no accounting for stupidity on the part of the end user :rolleyes: **</span>

This post has been edited by mrxak : 15 February 2007 - 03:21 AM

Find ~/Library/Application Support/Darwinia/full and open up 'preferences.txt'. On the line that says 'Mod =', make sure that it is set to none (i.e. 'Mod = none'). Also, for good measure, set 'UserProfile' to the profile you wish to use.


And of course, if that doesn't work for some odd reason, you can delete the entire ~/Library/Application Support/Darwinia folder. (or just move it somewhere else, to be safe)

Fantastic. 😄
I'll give it a whirl when I get home this evening.