Text error (63356 chars in one line) loading game

bug report

Running the "mine" or "generator" levels for extremely long periods of time eventually ends up with a file that causes the game to stop behaving properly, and quitting out will result in an error that a .txt file contains a line with more than 63356 characters in one line.


  1. Install Darwinia (and register, have to play past containment)
  2. Play either the mine level, or the generator level (generator is easier to mass spawn darwinians)
  3. Build up such that the triffids are firing the eggs at masses of darwinians, who then gun down the egg spawn and have engineers gather the souls, making more darwinians
  4. The objectives will continue to occur as normal, but exiting the level and trying a new one will result in the erroneous behavior.

After completing the level (I took a really long time doing it, didn't know that was going to bite me later), I went to do the escort level, but couldn't create any new units. I could turn all the darwinians into officers, but that doesn't help much, since I couldn't make any engineers to gather the souls from my darwinian shock troopers.

Any level I tried, I could load it up, but I couldn't create any units. The gesture worked, and it said "Running Program: <name>", but I couldn't actually get the units to spawn.

I think I had around 200 (at least) darwinians on the shore of the island in the generator level, just blasting at any triffid eggs that would come over. Plus the 4 (or is it 5) darwinians at each of the solar plants.

When I quit out of the app to try and relaunch (to see if that fixed things up), it failed to start up, and gave a small error box. I don't have an exact copy of the text, but it said something about a .txt file containing a line with more than 63356 characters.

I copied the redshirt2 decrypter stuff, and tried to decrypt the file (for the generator level), and it would only decrypt part of the file, the rest was all garbage.

I deleted the files and made a new profile, but I can probably reproduce this if necessary

I have two quick questions as I try to reproduce this:

First, you mentioned Mine and Generator. Does similar behavior occur in Escort (where, again, there are triffids creating virii that can be turned into DGs) or Biosphere or Temple (where there are spawnpoints that can be used to create virtually infinite DGs)?

Second, does it specify which file is being affected? I can only think of two files that should even be written by the game: 'game.txt' and the mission file for whatever mission you are playing. You said you tried to decrypt 'mission_generator.txt' (or whatever the mission file is called... I don't have it handy right now). Did you keep the corrupted file, and could you attach it to a post so that we might have a look at it.

It might also be useful to know what kind of system you are running on, though I am not quite sure what this might tell us. Processor type and speed, graphics card, &c. would be nice to have; and it whether or not you are running Tiger.

Okay, I am going to go try something, and see if I can reproduce this with a modded level...


coder1, on May 12 2005, 01:47 PM, said:

Any level I tried, I could load it up, but I couldn't create any units. The gesture worked, and it said "Running Program: <name>", but I couldn't actually get the units to spawn.
View Post

I can't think of a reason for the first bug, but I'll pass it onto the beta list.

As for the one I quoted above, that occurs in the pc version as well, and has yet to be pinned down. If you can find a reproducible cause for it, that would be awesome.

I've finished the Yard level now by using darwinians to fight the ants, resulting in at least 5000 of them (the whole island is green). I've seen no problems yet though, and the game doesn't slow down either (if the ants are destroyed I get the 9 fps again I get when I start the level, despite the giant mass of darwinians).

The Yard level is a level where you can build up the population very quickly though; just use level 2 darwinians to shoot the ants and let the engineers collect the souls. No darwinian will die and the engineers will also almost never die yet delivering loads of souls into the converters.

I noticed one strange thing though; with the mass of darwinians some viruses on the other side of the level (the red arrow things, most basic) just stopped moving! Like the AI has a limit of units to control or so...

This post has been edited by Leen : 13 May 2005 - 01:09 PM

I managed to reproduce the part with not being able to spawn units (though i could still make officers) -- haven't been able to reproduce the corrupted file (63356 chars in one line) yet.

On temple, just set officers up at the island so that all your darwinians hop into the transmitter and end up on one of the viral islands. after a short battle, the field starts to fill with souls -- when the email action kicks in and turns all the souls (or any living darwinians) into badguys, your island kicks into overdrive and spawns more darwinians -- eventually you get enough stuff in game (i think my ...temple.txt file was 560k when i looked last), that it won't spawn anything for you.

Quitting and relaunching worked for a bit, till the darwinians/virii/red army kicks in enough to spawn a ton more.