plugin creation problems

Hey guys, I need some help concerning the creation of new plugins. Let me start by saying that I just recently got this game back after losing it due to a computer crash and that I never had these problems before. Also none of the plugins I made before were uploaded, they were for personal use only.
Whats happening is that when i go to save a new plugin, it shows the icon with a lock over it and doesn't show up in the plugins folder where its saved. I can still open it in EVNEW, but it wont show up in game or the folder. Now in a strange twist of events one of the plugins i made suddenly showed up after I added some download plugins, but after i went back and modified it, it disappeared again. I have also tried to add the data into download plugins with no results.

I have searched these forums extensively and can't seem to find anything that matches my problem. I did find something concerning hidden files and followed that advice but it didn't change anything.

fyi the game is registered and I'm using windows 7, before the crash it was on vista, don't know if this matters or not

if anyone has some insight into this it would be greatly appreciated

Welcome to the boards, lambu-1! I’ve been told that Windows Vista and above can be touchy about programmes editing directly within the Program Files folder. Does it work if you edit your plug-ins on the desktop, and then manually move them into the Plug-ins folder using Windows Explorer?

Thanks for the welcome.
Haven't tried that, however i did figure out how to get the file to show up by running evnew in administrator mode, but i still cant get the ship to show up at any shipyard in the game. I've been looking at another ship that I downloaded as a reference (which does show up at ever shipyard), but it still won't show up, even tried running the game in administrator mode.

edit:
ok I don't know what i was doing wrong but i copy and pasted the reference ship into the new plugin, changed the id to match and now its working, now to see if the weapons will work

This post has been edited by lambu-1 : 13 March 2012 - 06:43 PM

If the reference ship works and yours doesn’t with the same ID, the first places to look are your ship’s TechLevel, Availability, and Require fields.

Alright I managed to figure this all out. Evnew won't save properly unless you run it in administrator mode, silly win7. And I finally got the weapons to work after a changed the id number to something lower, guess it doesnt like 500 and up. still need to fine tune the details but at least things are working now 🆒

AH HA! the tech number was what I was missing, all the others were set right, but i looked at it right after reading your post and sure enough, the ref ship was 1 and my ship was 200 :duh:
thanks a bunch

@lambu-1, on 13 March 2012 - 07:49 PM, said in plugin creation problems:

And I finally got the weapons to work after a changed the id number to something lower, guess it doesnt like 500 and up.

Your wëap IDs should stick to 128 through 383.

Well I seem to have hit another wall, the new ship is working fine but now the new weapons I created for it stop working as soon as I buy any standard outfits for it. The secondary weapon also disappears from the selection screen. I also can't get these weapons to show their names in the ship info screen. The weapons have outfits but no description, could this be part of the issue?

Log in to reply