Shipyard problem with picture

works on Mac, not on PC

I have a ship that that I took from a TC and put into my personal plugin collection. The ship shows up in the shipyard just fine. I have a picture and everything. I then used mission computer 4.0.4 to convert it to .rez and transferred the file to my pc and tried to use it on the same version of the game. Other ship that I have done this to have shown up fine. Is this just a matter of corrupt data and I should try again or could it be something else?

Try again first. If the bug's repeatable, we may have a problem.

I took the mac version and used Mission Computer to convert the file to the PC version in the same folder (after deleting the old file)

I then copied the file back over to the PC and put it into the plugins folder after deleting the original.

I created a debuglog.txt and pilotlog.txt and then ran the game. I came up with the same problem; no picture.

I thought of trying the converter that comes with the PC version of EVN, but as far as I could tell it just flashes up on the screen and is gone.

There are no errors in the debug log relating to this ship. It is still odd that this is the only ship affected by the move.

If it is corruption, you wouldn't have the link to the current location of EVNew would you? The one for the Plug Ins site is a dead link. I think someone is in control of the program now. I suppose I could take the components and put them through the software and rebuild the plug.

It sounds like the picture is getting corrupted, or the debug would tell you there's no picture. It's nothing I can help you with, except to suggest starting a new plug in and copying all the resources over, then saving that as a .rez

PICTs are unfortunately a bit voodooish, perhaps as a result of being designed for good performance on 1980s computers with limited resources. That's why the format has been superseded by newer ones.

Your post seems to suggest that you copied the picture using MissionComputer. How did you do it – by copying the entire PICT resource , or by copying the picture itself and pasting it into a new PICT resource in the other file? The former does a byte-for-byte copy, whereas the latter requires that MissionComputer encode a new PICT resource, which isn't always identical to the original.

I copied the picture from one plugin to another. I can't remember if that plugin was PC or not but if it wasn't, it worked fine on my Mac. ............I have looked for the exact plug-in that I got the ship from but haven't been able to find it. As I said, I just copied the pictures from one plug into another.

I will try copying the resources into a new file and saving it as a rez file

Figured it out........well, sort of. I used Photo shop and edited the picture a little bit. Then put it back in the plugin. Now it works.

Log in to reply