rleD issues

I don't know why this particular image is giving me so dang much trouble, but I've been trying to stick it into EVNEW all afternoon, and it just won't go. Could be Vista, could be I'm doing something wrong. I've got it in a nice, neat grid, 64x48 pixels per frame (smallish for a ship, but this one is a bit on the tinier side.) I've tried saving it in several different file formats (EVNEW should do just fine with JPEGs, but just to be safe, I also tried GIFs and even PICTs.) Everything else I've stuck into EVNEW seems to work just fine, it's only this one that seems to be giving me the issues. In fact, I'm mildly frustrated at the fact that when I import the exact same picture as a PICT resource, it seems to do just fine with it. It's only the rle's that are balking.

My procedure, if anyone can spot where I'm going hideously wrong is:
1. Open up EVNEW and create a new blank rleD resource.
2. Hit import, browse to the file, and put 64 for width, 48 for height, 6 for Y frames, 6 for X frames, 1 for first frame, and 36 for total frames. Same for mask.
3. Hit okay, and it gives me the picture, but it tells me the height and width are 0, and the mask looks pretty darn funky.

I've been doing the plug stuff for a while, but this is the first time I've tried to create sprites from scratch. I'm not particularily bothering with the rle8s unless I have to, but I don't believe that's the problem. If anyone could give me a hand with getting this encoded as an rleD, I'd appreciate it.

Pete

Attached File(s)

Ugh, it's been a couple years since I've poked around with EVNEW. I wrote the first version of my battle arena plug with it, and loved it, but I had to work backwards when creating new rleds for the plug. I think you have to put the X and Y values of the individual frames, as opposed to the entire image. So, try 8 and 6, respectively, then. The number of frames then tells EVNEW how big the entire image is.

If that doesn't work, I'm sorry, it's been too long since I've actually used the program to know for certain. My advice after that would be to open up some of Nova's plugs that have ship graphics and look at how those rled's are laid out.

This post has been edited by GutlessWonder : 19 December 2008 - 11:04 PM

I can't really help with your problem but for love of all things sane, do not ever use jpegs! They are lossy and the ones in your attachment are noticeably bad. Always work with lossless formats like png (or pict) when making images or sprites for Nova.

Well, I've got PICTs of each as well, but it doesn't seem to matter which format I use. I tried everything I had in the book: JPEG, GIF, TIF, PICT, even bitmaps weren't working. They all give me the exact same issue. The mask itself appears fine until I import it, and the sprite base seems to import all right, but when I put in the mask, it gives me some sort of wacky fuzzy thing instead of the mask I want. Even importing it into EVNEW as a pict resource and then exporting it back out and importing it again as an rleD isn't working.

I did put in the actual sprite size and then the x/y tiles instead of the image total size when I was putting this in yesterday, and I thought maybe that's where I was having the trouble, but attempting it any other way didn't get me anywhere either. I'd attach the PICT images, but it seems that they're just a bit too big (even zipped) for the upload max. Anyone else got any ideas? Or a better Windows based rle encoder? I knew I should have just bought the Mac...

Thanks much!

Pete

Try converting the mask into a 1 bit mask using GIMP or a similar program. I recall EVNEW having issues with masks that were full 24/32 bit colors with only black and white.

Also, I use .pngs for sprites. If you haven't tried it yet, it might be a good idea to.

@krugeruwsp, on Dec 21 2008, 11:14 AM, said in rleD issues:

but when I put in the mask, it gives me some sort of wacky fuzzy thing instead of the mask I want.

That'll be caused by the jpeg compression and is precisely why you shouldn't use them :p. Can you make it again and save it as png instead?

You want an RLE encoder? Fine. I'll get started - shouldn't be too hard, since I already have a decoder.

PNG compression may improve filesize for attachments. One of many advantages of PNG is that its compression is actually used on the 2-dimensional object, as opposed to a 1-dimensional stream of bytes like generic compression algorithms.

Finally got it. The trick seemed to be in flattening the PNG mask down to a 1 bit image. Just doing it as a PNG alone still made it screwy, but reducing it seems to have appeased EVNEW. I will certainly have to use PNGs from now on. I've just gotten used to using JPEGs because of my planetarium work. We use a program to transform digital images for use in a dome theater, but it only understands bitmaps, targas, and JPEGs. Bitmaps were unwieldy and couldn't be sent to the slide producer, targas were ridiculously huge and the upload took ages, and that left JPEGs.

Anyways, much appreciated on the debug help!

Pete

Ah yes, if your original image was an alpha mask (with shades of grey rather than just straight black and white) then it could cause problems with EVNEW. Great to hear you solved it 🙂

Jpegs are great for heaps of things like photos and other highly detailed images, they just have no place in the context of Nova. PICT and rleD resources are both lossless so using lossy formats in-between serves no purpose other than to decrease the quality.

Log in to reply