Please tell me if Strict Play Test works for you

help test a proof-of-concept plug-in

Poll: Strict Play Test should say whether a new pilot is or is not on strict play (6 member(s) have cast votes)
Does Strict Play Test work correctly for you?
Yes
(5 votes [83.33%])
Percentage of vote: 83.33%
No
(1 votes [16.67%])
Percentage of vote: 16.67%

Please find attached Strict Play Test.zip. I want to know if it doesn't work for anyone. Which means I'd like to know who it does work for as well. When you run Nova with it as a plug-in, you should create a new pilot, then enter the ship. If it works, the screen will be mostly white and a dialog box will pop up saying either, "This pilot IS on strict play." or "This pilot is NOT on strict play." The text should accurately reflect whether the pilot is on strict play. Please try making a few pilots and tell me if it does or doesn't work properly for you. Thanks,

~Qaanol

Attached File Strict_Play_Test.zip (2.33K)
Number of downloads: 8

Attached File Strict_Play_Test_2.zip (2.38K)
Number of downloads: 4

Please try Strict Play Test 2 as well. If either one doesn't work, please let me know.

This post has been edited by Qaanol : 26 November 2008 - 07:29 PM

It works. And now that that's over with, I'm going to have to figure out how you got all that to work...

And by the way, the "mission failed" string appeared at the bottom of the screen when I entered the pilot. I believe this is preventable, but may be mistaken.

It didn't work for me under Wine; it always displayed "is NOT."

The "mission failed" may be over-writable with a Qxxx.

It looks pretty clever. I can't be bothered trying to work it out so just tell us :). Why the white background?

Did you have particular use for this in mind?

This post has been edited by Guy : 26 November 2008 - 06:27 PM

I think you might have too much free time on your hands. Good job!

It works

(EDIT) My system:

Late 2008 Unibody MacBook Pro
Mac OS X 10.6 (kidding)
Mac OS X 10.5.5

This post has been edited by Geek : 26 November 2008 - 06:42 PM

On closer examination, it works properly for me on the first pilot that I create after launching Nova, but any later-created pilot always says "is NOT."

My guess on how it works is something about the speed boost. The system is white so you can't see the little dots move.

Edit: for emphasis. Since no one else has yet reported error, I can't ask them to check this. Although, did anyone respond to the poll with only a single success?

This post has been edited by Nonconventionally Creative : 26 November 2008 - 06:47 PM

Nonconventionally Creative: You're saying that after the first pilot, subsequent new pilots on strict play read as if they were not on strict play? That is strange. I know it doesn't work if you enter the ship with the same pilot a second time, but I wouldn't expect what you're seeing. Regardless, I think I know how to fix it even if I don't know why it's happening. Please try the attached Strict Play Test 2 and let me know how it goes.

Attached File Strict_Play_Test_2.zip (2.38K)
Number of downloads: 4

Yes, it works using the speed boost.

Guy: My intended use is to Gxxx an outfit that negates the non-strict play speed boost.

Now it works maybe 50% of the time, maybe a little less. I didn't take extensive data this time. The previous time I took enough that I felt confident it "always" happens.
Has anyone tried this in Windows yet? It might be Wine. Wine gives a debug message about "fixme:d3d:IWineD3DDeviceImpl_CreateSwapChain The app requests more than one back buffer, this can't be supported properly. Please configure the application to use double buffering(=1 back buffer) if possible." Also, Nova runs somewhat slower in Wine than natively, which might affect it; my normal framerate is about 18. People reporting system specs ought to also report their framerate.

@nonconventionally-creative, on Nov 27 2008, 11:44 AM, said in Please tell me if Strict Play Test works for you:

The system is white so you can't see the little dots move.

If the little dots were black then you could have a black background 😉

@qaanol, on Nov 27 2008, 12:29 PM, said in Please tell me if Strict Play Test works for you:

Guy: My intended use is to Gxxx an outfit that negates the non-strict play speed boost.

Ah, good idea.

All right, thanks NCC, I think I know why it didn't work correctly. Attached are two new versions, and I hope they both work. Noticeably different is the system background is now black, so you can see the little dots moving. And instead of popping up a dialog and moving the player to a different system, it simply displays a message at the bottom of the screen saying whether the pilot is on strict play or not. Also, you can target everything in the system, and there are labels, so the ships called "Disables on strict play" and "Disables on nonstrict" ought to end up with exactly one of them disabled, and it should be the right one. Thanks so much for testing this, please let me know how these new versions work.

What you should see is your ship's dot moving upward (so everything else moves down the screen.) If you're on strict play, there should be a dot almost on top of your ship at first moving with you, and then it gets disabled. If you're not on strict play, there should be a dot almost on top of your ship at first moving upward slower than you, and it doesn't get disabled. There should be a dot that moves suddenly to the right and disables a different dot.

The difference between the two new versions is only in the prox radius and blast radius of the weapon that does the disabling. Version 3 has radius 3 for both, and version 4 has radius 5 for both. If lag is somehow affecting things, one might work when the other doesn't.

Attached File Strict_Play_Tests_3_and_4.zip (5.01K)
Number of downloads: 3

With 3, most tests, both on strict play and not, do not give any status message. Some non-strict play tests return accurately. Some strict-play tests return either value.
With 4, non-strict play returns correctly. Strict play sometimes returns each value.

I'm betting the problem is caused by your low framerate. On a proper Windows machine it'll probably work fine.

I guess I'll see to that...

Edit: On my Windows XP machine that runs at 45 FPM I ran three tests; the first and third were for strict play, and the second was for non-strict play. All tests went successfully, with the minor exception that I was never transferred to a shuttle proper and got stuck in a dot. I think this was intentional, however, but am not sure. It could be something screwy about WinNova.

This post has been edited by JacaByte : 28 November 2008 - 04:23 PM

For 3 and 4, yes that was the result found, presumably for the ability to see and track the ships.
I just tried this in Virtualbox (which gives Nova a worse framerate than Wine does) and my previous results were matched, so the problem isn't in Wine.

Try something a little less graphics intensive, such as TCTC. I've gotten FPS rates as high as 54 with TCTC on the Windows machine, so try using the plug-in with TCTC.

Yes, that was intentional, I forgot to update the readme to say so. I'm glad it works now. Thanks everyone.

Log in to reply