My asteroids are afraid of commitment

All of a sudden all the asteroids have disappeared from Ashen Galaxy. I'm not getting any error messages, I haven't broken any file size limits, and all the relevant files seem to be uncorrupted. Mind you, I haven't checked each röid and RlëD resource, but there are enough of them that some asteroids should be showing up. I haven't touched anything related to asteroids for quite some time, so I don't know how this could be. The game seems to think that the asteroids are still there (as evidenced by the way my astro miners tweak out).

I'm sure the solution is childishly simple, but, for the life of me, I can't figure out what could be wrong.

First, I'd recommend you double check the Roid, RleD and syst stats. If this doesn't work try running Nova and see if the same error occurs. Finally if it shows on Nova, you might need to try to find a back-up.

So, this occurred only after those fixes? You have not committed anything with those changes; I checked the timestamps.
If they are physically there, just not visible it would logically be the graphics... And the graphics are stored in AG2, which also contains things more easily noticable such as planets and stars... I have no idea.

All the resources are there and as far as I can see, uncorrupted. Could it have something to do with MC? I copied all the files in from Nova, so there shouldn't be any chance of corruption. The size three and four asteroids appear, as far as I know they always appeared. The size one and two asteroids appear when I destroy the larger roids. Nova seems to think the smaller asteroids are drifting around the system, but it won't draw them and the astro miners don't recognize them.

The smaller size asteroids aren't appearing in stock Nova either. Or in any of the copies of Nova I use for other TCs. I think that rules out any sort of file corruption. It's worth noting that I didn't notice this until after I changed from a PPC to an Intel iMac.

So, your videocard is not drawing a certain kind of texture. This may be related to the "direct to screen" drawing that is fixed in 1.1. Is there any option somewhere to disable hardware acceleration? Is there an updated driver?

Guy found something about asteroids and screen resolution but I don't remember the specifics. Try replacing the asteroid sprites with sprites of substantially larger pixel dimensions.

Have you gotten anybody to report similar behavior?

Fix for Nova in sig. If you have made your own roid sprites you will need to make sure they are at least 50x50.

This post has been edited by Guy : 24 October 2008 - 11:04 PM

@guy, on Oct 24 2008, 09:02 PM, said in My asteroids are afraid of commitment:

Fix for Nova in sig. If you have made your own roid sprites you will need to make sure they are at least 50x50.

Phew. Thank you. I'm relieved that you know the answer. It works.

This post has been edited by gray_shirt_ninja : 24 October 2008 - 11:12 PM

@gray-shirt-ninja, on Oct 24 2008, 11:15 PM, said in My asteroids are afraid of commitment:

Could it have something to do with MC? I copied all the files in from Nova, so there shouldn't be any chance of corruption.

Check what Guy has suggested as well, but if by any chance you're using MissionComputer 4.0.0, you should upgrade to 4.0.1. The initial release had a bug which could cause the Copy command to lose a single byte under some circumstances, which affects RLEs much worse than most resource types.

I've got version 4.0.1, and Guy's fix works. Thanks for the help.

Log in to reply