EV Override 1.0.2fc4 semi-public beta

For those of you who participated in testing EV Override 1.0.2fc2/3, I'd like to thank you for your help and enthusiasm. Thanks to you, we found and fixed a few of problems in EV Override 1.0.2 -- kudos for catching them and helping us make EV Override 1.0.2 a clean, stable release. Moving ahead, we now have EV Override 1.0.2fc4 available (please see below for details).

For those of you who are new to this, we have been working on EV Override 1.0.2, which adds a significant number of changes to the game that are of direct interest to plugin developers. We think that it's ready to go, but we'd like to do a semi-public beta test of it first. Thus, the reason I am posting this message here.

I'm assuming that if you are reading the EV Developer's web board, you have an interest in developing plugins for EV/EVO -- we'd like you to try out what we think will be the release version of EV Override 1.0.2, before we release it to the public. We'd also like you to be able to take some of the new plugin capabilities out for a test drive. Perhaps it'll inspire you to add features to your plugin, or to make a new one.

If you find any spelling errors, and grammatical mistakes, any bugs, any features that don't work as you'd expect (please do NOT ask for new features) -- please mail them (do not just post them to this web board) to:


...so we can take care of them before the game is released to the general public. Also please note that you probably shouldn't pass this info along to general EV Override players; they will be better off waiting for the official release from us (which will be happening shortly).


*** This is confidential information, you'll be hurting us rather than helping us if you give it out ***

EVO1.0.2fc4 is now available in the /beta directory of our anonymous ftp site as:


So the complete URL is:


This file is a MacBinary II encoded self-extracting archive, encrypted with the password:


To quote Matt Burch: "If this is not the final release version, I'll eat my mousepad." So in the spirit of having Matt munch on some latex...

Please grab this file as soon as possible, and begin testing it. We're hoping that this version of EV Override is the final release; please test it out on as many different Macs/OS versions as you can, and with as many third-party plugins as you can as well.

Please make a point of checking over the EV Override FAQ as well (it's in the "Documentation f" folder").

Here's the changelist from Matt:


-- Fixed even more beam flickering problems

-- Fixed looping beam sounds

-- Player now gets no speed bonus when Strict Play is checked

-- Fixed some spelling errors in various mission text

-- Included an EV Override FAQ

Andrew Welch / el Presidente / Ambrosia Software, Inc.

Eat it up Matt...

Hmmm... Will you eat the mousepad if there are problems in the FAQ too, cause I've already found two.



Did you fix that grammatical mistake? Peter Cartwright knows what I'm talking about. If not... hope that mousepad tastes good, Matt.

God. Root. What is difference?

AIM: obormot345

The only problem I had was that pilot files made with earlier versions didn't work. This means I had to use a cheater plug-in to get the beams(they worked, BTW) I also made a plug with different beams in it, they all worked.

I'll test it some more tommarow.

"I never use shampoo with milk or eggs. These are imperialist ideas" - Libyan leader Muammar el-Qaddafi


Yahoo Messenger-OctoberFost


(url="http://"http://www.geocities.com/octoberfost/chatroom.html")Unoffical EV/O Chatroom(/url)


Originally posted by OctoberFost:
**The only problem I had was that pilot files made with earlier versions didn't work.

I'm wondering how big of a deal this is; my feeling is that people will be fairly ticked off if their 1.0.1 pilot files no longer work. Opinions?

Andrew Welch / el Presidente / Ambrosia Software, Inc.


Originally posted by Obormot:
**Did you fix that grammatical mistake? Peter Cartwright knows what I'm talking about. If not... hope that mousepad tastes good, Matt.

Yes, it was fixed (but isn't part of the update) -- in any event, it wouldn't be considered a but rather a "bad translation" so to speak. 🙂

Andrew Welch / el Presidente / Ambrosia Software, Inc.

I think people will be peeved if their pilots don't work, but will be even more peeved if their old plugs don't work.

I haven't been arround here reading every post, so I don't know... do old plugs work with EVO 1.0.2?

Dan! The food's gone!


Originally posted by Jericon:
**Eat it up Matt...
Hmmm... Will you eat the mousepad if there are problems in the FAQ too, cause I've already found two

C'mon, let's be reasonable -- problems in the FAQ are not bugs, and clearly not Matt's problems. If you do come up with anything wrong with the FAQ, please mail the issues to:


Andrew Welch / el Presidente / Ambrosia Software, Inc.

You mean to say i just spent the last hour checking spelling and then you release fc4?

God Damn!

On the basis i have nothing better to do, i have a long list for you shortly 😃

"Where the f*** have the bunnies gone?"
- Unknown

AIM - EST champion
eMail - champion@metallica.com
- phalanx2@today.com
- rob_the_god@hotmail.com

All things have a purpose. All things that have no purpose cease to exist.

Heres a bug i found. Its not a big one, but its there. Under misn resource, and the field:
AvailLoc Where on a planet this mission is available
0 From the mission computer
1 In the bar
2 Both
2/both doesn't work. When you put two here, the mission doesn't show up at all. This is with prob at 100, and all the other stuff correct because the same mission works with 1 or 0 in this field.

Heres some errors I found in the newest edition of the EVO bible.

range should be 10000-10127 for specific government for the following fields, not 9999-10127, because there are only 128 govs, and that range covers 129. The first number recognized is 10000, as used by EVO itself for UE missions:

under Misn:

under Pers:

Also in the mission resource it states "A quick word on mission bits:" theres 512 mission bits now, not 256, change to "Override stores 512 flags..."



Originally posted by andrew:
**I'm wondering how big of a deal this is; my feeling is that people will be fairly ticked off if their 1.0.1 pilot files no longer work. Opinions?

I have to say...I was REALLY PISSED when i couldn't use my old file. But...such is life. I am going to restart and just use a cheat plug until I catch up with my old self!

From Left Hand Phoenix of the AWL
Halo, Homeworld, and Diablo II.

(This message has been edited by Phoenix155 (edited 06-04-2000).)

Fuel Regeneration Bug?

The Cargo Transporter and the Freighter are not giving fuel regeneration. I checked the data files with res edit and found that the Cargo Transporter does not have the 0x0008 flag set. The freighter has the correct flag but it still does not work. I created a plug-in and copied the freighter's info from the original files to the new plug. When I started the game with the plug the Freighter's regeneration works. Without it the regeneration does not work. I did not add anything. I simply copied the original information. For some reason Regen only seems to work with a plug-in.

Is anyone else having a problem with fuel regeneration from the Cargo Transporter and Freighter?


After being obliterated by the Voinians, Verril Prime still has a spaceport bar. The bar has no description, so I assume it should not be there.



Originally posted by Thursday:
**I think people will be peeved if their pilots don't work, but will be even more peeved if their old plugs don't work.


I agree. Do the old plug-ins work? Has anyone tried testing any of them (like Femme Fatal, for example)? It would be nice, too, if the pilot I am currently using would work when I upgrade. 🙂


Okay, here's some problems with the EVO FAQ (I will also e-mail this to help@ambrosiasw.com😞

(Q) What is the Strict Play option?

(should also mention "no speed bonus for player's ship.")

(Q)Is there a find feature for the map?

(should also mention that red arrows point to the destinations of accepted missions. ...And doesn't a green arrow point to the destination if a particular mission is selected from the list of accepted mission?)

(Q) How do I receive missions?

(should also mention that some missions are only available after completing other, or after obtaining a certain combat rating or gov't status. Also...that some missions will be offered at times in the spaceport bar.

(Q) How long did it take to finish EV Override?

(unfinished second sentence)

Other questions that I think need to be answered in the FAQ:

Why is it called EV "Override?"

Will you please list the complete lists (with numbers) of the combat ratings and gov't status?

Why doesn't the System map on the outfits screen indicate whether the player has already bought one in that system?

How can a player save a copy of a pilot so that it can be restored later (to prevent having to start over) if the player makes some choices that puts her/his pilot on a path she/he didn't want to take?



(This message has been edited by Jude (edited 06-04-2000).)

Incidentally, in the FAQ, there are constant references to EV:

(Q) - I can't launch any space-borne ships; why?

(A) - You need a launching bay on your main ship in order to use space-borne ships. After you purchase ships for your bay, simply cycle through your secondary weapons until it lists either Hawks or Lightnings.


(Q) - Why can't I hit anything with my space bombs?

(A) - Space bombs are launched with half of your ship's velocity, and then they "sail" unguided through space. Whenever they get near a ship, they detonate. The simplest way to use a bomb is to fly over your enemy and drop one. Another way is to fly backwards directly towards your target, then drop the bomb and hit the afterburners. You can also "lob" space bombs at ships since they go the direction you're going at the time of launch. It is feasible to use them as mines as well: if you drop one while you are stopped, it stays stationary.

Space bombs? What space bombs? There are space mines...

I'll mail these in soon enough.

"His Strangelove All-Purpose Do-It-Yourself Defensive First Second or Third Strike Indestructible Fantastic State-of-the-Art B-Ware Offensive Attack Bomber can't compare with our M & M E & A Sub-Supersonic Invisible and Noiseless Defensive Second-Strike Offensive Attack Bomber."
- from Closing Time , by Joseph Heller.

Some grammar errors in the new "Pay Fine" mission:

dësc 4511: "...you have been charged with the purchase an possible use of illegal armaments..." should be "purchase AND possible" use, not "purchase AN possible use".

dësc 8511: "Your case is dealt with satisfactorily promptly at the Court..." sounds rather awkward. Suggest "dealt with satisfactory promptness"

"...assuming you do not repeat the offence that is." seems to suggest that a second violation would result in a larger fine and reduced legal standing in the UE. You should either set up a compbitset and a second mission with a harsher penalty, or remove the passage in question. Also, "offence" should be spelt "offense".


"Now, Mr. Mirnas... start at the beginning."

-The Interrogator

I don't know whether this still applies in fc4 (I haven't gotten it yet), but setting the default second trigger to option still causes the problem that you may accidently fire your weapon at someone you didn't want to or when you didn't want to. Example: You have your fighter bay selected and you want to call your fighters back in. If you still had one in the bay, it comes out and might not get the signal to come back. Another Example: You have a missile selected (say, a hunter missile) and you want to check on the health of your escorts. So you start to cycle through your targets with the option key down. Suddenly, a missile flies out and hits a carrier. Not exactly the best way to keep the UE happy with you...

The point is, I think the default Second trigger should be moved to the control key, since it doesn't have any other functions.

Knucklehead, Aeon Productions


(Insert witty remark here)

I haven't been able to test these phenomena very thoroughly so I'm looking for some second opinions before emailing them in.

I started a new pilot file and got to the mission where they give me the cloaking device. I quickly whipped up a cloak keep type plug-in and proceeded with my game with the plug-in in. Low and behold when I pressed the 'U' button nothing happened. I quickly discovered that I had not recieved the cloaking device. Has anyone else had the same problem? I can't believe I made the stupid move of spoiling the test results with a plug-in...

Also I made a plug-in just to have fun with the X offset feature. I gave X offsets to all aradas, the lazira and the Miranu gunship. I also made them cost nothing and have a tech level of 1 so I could try them out. Of course when I pasted the resources from the data file into my plug-in and then opened them I got an error message saying the template was too large and zeroes would be added or something. As far as a I can tell, this just referred to the new fields in EVO 1.0.2, for some reason this seems to include yet another "Unused" field.

When I tested my plug-in I found that none off the X offsets worked.

"Landing request denied."

Company Tritanium Enterprises: (url="http://"http://www.megalink.net/~joe1/w/")http://www.megalink.net/~joe1/w/(/url)

I noticed the problem with the Templates being too big for the actual resources in fc2. However, it shouldn't cause too much of a problem, just remember to change the 0's (zeros) to -1, just to be on the safe side.

Meanwhile, I can't seem to get fc4. The last 2 were almost small enough to fit on a floppy (they did fit after I zipped them), but fc4 is too big to fit, even zipped. If I had to guess, I'd say the new FAQ made the archive too big for a floppy. I tried manually splitting the files, but they always mess up by the time I get them over to the mac. Does anyone have any suggestions about how to get it? One possible solution is for someone to take the .sea file and binhex it with Dropstuff. Binhexed files are easier to split. If anyone can help (I'd really like to continue testing this), please Email me at (url="http://"mailto:knucklehead_c@yahoo.com")mailto:knucklehead_c@yahoo.com(/url)knucklehead_c@yahoo.com