f-25 (v2) help

I'm stuck in the beginning stages of f-25. I've taken the scientist to New Mira and grabbed some stuff to take to Mira. Now, I've accepted the mission taking the convoy past North Tip Station... Except... No convoy ever shows up! I've been to many diff systems in the area, but nothing happens... even at North Tip Station, or even if I just go all the way to F-25. Any ideas?

PS- I'm in a souped up Igazra with 2 CW escorts... I don't think either of those ships were supposed to cause problems with F-25, so...



I had this problem too. What you have to do (I think) is get the mission to take the convoy to F-25.
Go to F-25. Land. Take off. Now go to Munb. Land. That should do it (I think).

"Give a man a fire and you keep him warm for a night, but set him on fire and you keep him warm for the rest of his life" - Sergent Colon


Do exactly what you said Scaryfish. It's a little wierd since it doesn't tell you
what to do.You just have to use the map as your reference. Follow the red tabs.

It's a great plug. Keep playing it.

P.S. TheElf later on the Marauder rocks all ships.

Why is Star Wars so addictive?

Hmmm... Still no luck. I don't get any red tabs when I get the mission. Strange. Any ideas?


The same thing happened to me, but I saw the red flag on Munb (btw, how do you pronounce that?), went there, landed, then went back to F-25. So far everything is cool. I had to take out a few extraneous plugins, but it's all good now. One question: Why in the universe did the Miranu choose to go through the Hreeka system instead of up from Kirrim system? Makes more sense to me to go that way. I guess they don't mind taking the long way 'round. One gripe: I had to go to Sol system in order to use the Pilot Builder plug. Why there and not anywhere else? Last question: How do you get the great pics for the map plugs? I get some great clues as to the missions after using the EVO Cat which reads the data files and creates one file for each mission, giving lots of information. The EVO Developer's Map helps, too. Or it did before getting into F-25.

See ya on the board!
Capt. Ace Harddrive
S.S. Green Bean
😄 😄 😄 😄


Hey y'all! 😉 😉

I've just gotten to Munb after the Hreeka/Zacha mission and was told to go to the bar. Well, guess what? Munb has no bar! I've tried going to Outpost Zachit and to Aenecia, but nothing happens! What do I do?


Capt. Ace Harddrive
S. S. Green Bean


When I dowloaded F-25, the read me file caused an error, but I think the rest of the stuff is fine. I put the titles, graphics, and "F-25 1.4" into the plug in folder. My question: Is all that correct? And if it is, must I start again with the F-25 pilot that was included? Thanks.


For cap. Ace go to the mission comp. on Mumb.

A Spisak

Why have one when you can have two for twice the price.

Just started F-25, but can't find the "Intruder" in Igadzra space, any help?

Willim McCrae
Captain of the bonnie
ship the "Diamond"

the intruder is supposed to be in Kavkaz. I have a problem. I have been unable to connect with the intruder there, have restarted the mission 3 times, been all over the galaxy earning points and looking. No intruder shows up in Kavkaz, south of Pozdag.

Any suggestions?